en

Logowanie

Nie masz konta? Zapomniałem hasła

Przypomnij hasło

close Wypełnij formularz.
Na Twój adres e-mail zostanie wysłane link umożliwiający zmianę hasła.
Wyślij
<< przejdź do listy wydarzeń
To wydarzenie już się odbyło. Sprawdź nadchodzące wydarzenia

PyTrening 2.0 # 15 Okienka GUI

Wydarzenie:
PyTrening 2.0 # 15 Okienka GUI
Typ wydarzenia:
Spotkanie
Kategoria:
IT
Tematyka:
Data:
11.05.2016 (środa)
Godzina:
18:30
Język:
polski
Wstęp:
Bezpłatne
Miasto:
Miejsce:
Centrum Wykładowe Politechniki Poznańskiej
Adres:
Piotrowo 2
Facebook:
Opis:
Specjaliści nie mają problemu z obsługą aplikacji uruchamianych w konsoli. Przeciętny zjadacz chleba potrzebuje jednak prostszych sposobów na komunikację z programem komputerowym. Taki użytkownik na pewno doceni możliwość skorzystania z interfejsu graficznego.
GUI można budować w Pythonie na wiele sposobów. Jedną z najpopularniejszych bibliotek umożliwiających pythonowcom tworzenie interfejsów graficznych jest Tkinter. Pakiet ten pozwala na budowanie zarówno prostych okienek, jak i skomplikowanych interfejsów. Jego nad pozostałymi, pythonowymi bibliotekami do tworzenia GUI polega przede wszystkim na tym, że Tkinter jest zazwyczaj domyślnie dystrybuowany z Pythonem. Pakiet posiada dobrą dokumentację, a jego popularność przekłada się na bogactwo dostępnych w internecie tutoriali i poradników.
Na najbliższych zajęciach nauczymy się podstaw budowania interfejsów graficznych z wykorzystaniem Tkintera. Dowiemy się, w jaki sposób budować okna zawierające najpopularniejsze widgety. Poza tym, poznamy sposoby na szybkie skorzystanie z palety kolorów, wyświetlenie ostrzeżenia, czy uzyskanie ścieżki do wybranego pliku na dysku.
Co jest potrzebne? Poza chęciami i uśmiechem na twarzy? Komputer z Windowsem/MacOSem/Linuxem i zainstalowanym Pythonem 3.4 lub nowszym.
Jak zainstalować Pythona na komputerze: Windows: https://www.python.org/ftp/python/3.4.3/python-3.4.3.msi MacOS: https://www.python.org/ftp/python/3.4.3/python-3.4.3-macosx10.6.pkg Linux: sudo apt-get install python3.4
Przed warsztatami sprawdź, czy z linii poleceń działa Ci python -V i wyświetla wersję python 3.4 lub 3.5. Sprawdź ponadto, czy jesteś w stanie zaimportować Tkinter w środowisku Pythona (import tkinter). Niektóre dystrybucje Pythonów 3.x wymagają niestety doinstalowania biblioteki Tkinter. W razie takiej konieczności, postępuj z odpowiednimi dla Twojego systemu instrukcjami dostępnymi na tej stronie: http://www.tkdocs.com/tutorial/install.html
Widzisz błąd w wydarzeniu? Wydarzenie jest nieaktualne? Poinformuj nas o tym! >>

Podobne wydarzenia